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Chapter 7

Remote sensing of distinctives
vegetations in Guiana Amazonian Park
1. Context and definition

1.1. Global context
The Guiana Amazonian Park (figure 7.1) have satellite imagery available all over
its territory. SPOT-5 sensor offers 10 m imagery resolution which allow detection of
peculiar vegetations [GRA 94] distinct from the tropical forest (which look like
broccolis florets from above). Remote sensing was used to detect those distinct set
of vegetations. The objective is to identify with the help of the spectral signature
those peculiar species and mapping them over the national park area. The result map
completed others French Guiana research projects such as the forest landscape type
[GON 11] and the forest habitat map [GUI 15].
Eventually, this methodology can be used to follow evolution of those
vegetations, including for climate change adaptation analysis [HOL 17], and their
evolution in medium and long term. Currently there is very few knowledges about
the origin of those vegetation. Bamboos (Guadua spp) lifetime should be around 30
years [NEL 05], but no details data allow to follow their spatial evolution [OLI 07].
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Figure 7.1. Location of the French Guiana Amazonian Park.

1.1. Species
Jean-Jacques de Granville identified several vegetations species in the south of
French Guiana [GRA 94]. Our study is concerned only by the species that are
grouped with at least 1000m² (figure 7.2) and so not scattered vegetations.
●
●
●
●
●

Low vegetation: (cambrouses which are bamboos or heliconias forests on
the riverside, Pripris -Wetland vegetation on the riverside),
Mauritia flexuosa forest,
Açaí palm forest (Euterpe oleracea),
Rocky outcrop (Inselberg with some vegetation)
Parinari forest: found in the Waki river area. This vegetation is found
in djougoun-pété soil (pits of one-meter diameter and from 30 to 50cm
depth).
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Figure 7.2. From left to right, Açaí palm forest, Inselberg, and bamboos forest.
(Credits: Daniel Sabatier - IRD).

1.3. Remote Sensing images available
There are different types of imagery available in French Guiana to realize this
project (Table 7.1). Imageries from SPOT-5 are chosen for this work because they
were the best resolution imagery available at the beginning of the project in 2014.
However, SPOT-5 doesn’t operate anymore, so the methodology was made
compatible with Sentinel-2 and Landsat-8.
Because the project area is in equatorial climate, it is impacted by clouds most of
the year. To avoid missing areas, the methodology use a superposition of several
images. At the end, 55 images, covering 23 SPOT-5 scenes were used to cover the
French Guiana Amazonian Park (Figure 7.3).
Landsat-8 et Sentinel-2 were assessed to continue this methodology with free
and easy of access data. The benefice of Sentinel-2 is its high temporal resolution of
5 days. It will be easier to have a complete cover of the area every year.
Sensor

Period

Spatial resolution
Multispectral Panchromatic

National
Park
coverage*

Landsat (5-7-8)

Since 1990

30m

15m

100%

SPOT-4

1998 - 2013

20m

-

100%

SPOT-5

2002 - 2015

10m

2.5m

100%

SPOT (6-7)

2014 - today

6m

1.5m

70%

Pléiade

2012 - today

2m

0.5m

5%

Sentinel-2**

2016 - today

10m

-

100%

Remote sensing of distinctives vegetations in Guiana Amazonian Park

Lidar

2014

SAR imagery
Sentinel-1**

2016 - today

1m
10m

4

2 mountains
(Itoupe and
Inini)

100%

* Cover for all available imagery
**Available after this work

Table 7.1. Satellite imagery available

Figure 7.3. Number of images available for each SPOT-5 scene to get a free
cloud coverage.

1.4. Software
The whole of this work was achieved with open source software (Table 7.2).
This provide an easier spread and best repeatability of the method. In order to easily
enable replication of this project is important to use well known classification
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algorithms. It’s why dzetsaka plugin has been developed. This name means “objects
used to see the world” (as a camera or a satellite) in Teko language (an Amerindian
language spoken in Oyapock river, in south east of French Guiana).
Software used (version)

Extension

Monteverdi

Optical Calibration

Qgis (2.14.14) *

GDAL library
Dzetsaka
Grass (6.4.3)
Orfeo Toolbox:
- Band Math
- ComputeConfusionMatrix

* Only the extensions to activate or not present by default are listed

Table 7.2. Software used for this project

1.5. Method implementation
Throughout the method presentation, an example with SPOT-5 imagery will be
detailed.
SPOT-5 satellite imagery has been acquired from the SEAS Guiana project.
SEAS offers free French Guiana SPOT-5 archives images to the government
agencies establishing in this territory (http://www.guyane-sig.fr/?q=node/88).
Same method was validated for Sentinel-2 and Landsat-8. Sentinel-2 provides
spatial resolution close to SPOT-5, but with a better temporal resolution (every 5
days). The work initiate with SPOT-5 can be go on latter with these new sensors.
Procedure and tools location can slightly differ according to the operating system
or the Qgis version used. This chapter has been verified with Windows 10, Qgis
2.14.14, Grass 6.4.3, and OTB 5.0.0.
2. Software installation
To success this work, dzetsaka plugin should be installed from Qgis extension
list. However, dependencies should be install first: python-pip, scikit-learn, scipy,
Grass 6.4.3, Orfeo Toolbox 5, and Monteverdi.
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Dzetsaka plugin is dedicated to make image classification directly from Qgis.
But to unlock all his capacities, several dependencies should be installed first to use
all the famous classification algorithms (as Random-Forest and Support Vector
Machine). For Windows installation, it’s better to use OsGeo.

2.1. Dependencies installation available in OsGeo
To update or install Qgis with all the dependencies, run the OsGeo installer
(available on the download page in Qgis.org), then select advanced installation.
Several libraries are available, but dzetsaka only needs python-pip and SciPy.
However, to do the atmospheric correction, Monteverdi is recommended.
Setup dependencies with OsGeo:
Advanced installation > Select Packages > Check
python-pip, scipy, Monteverdi, grass 6, otb-bin

To install a dependency, it requires to click on the Libs category and select Install
instead of Default after having entered the dependency name in the search box.

Figure 7.4. Dependencies installation in OsGeo

Once dependencies have been installed, open Qgis and click on Menu >
Processing > Options > Providers, then activate GRASS commands.
Grass default directories are:
-

C:\OSGeo4W64\apps\grass\grass-6.4.3 for Grass 6.4.3
C:\OSGeo4W64\apps\msys for MSYS, essential to link Grass and Qgis.
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Figure 7.5. Settings for Processing toolbox

If needed, Orfeo Toolbox default directories are:
-

C:\OSGeo4W64\bin for tool directory
C:\OSGeo4W64\apps\orfeotoolbox\applications for applications directory.

Figure 7.6. Orfeo ToolBox settings in Qgis.

2.2. Installation of scikit-learn
Scikit-learn is the reference python library for automatic learning. It is necessary
to use famous classification algorithms such as Random-Forest (RF), Support Vector
Machine (SVM), or K-Nearest Neighbors (KNN). Unavailable in the OsGeo tool, it
needs a little handling in the OsGeo terminal to implement this feature.
Setup scikit-learn library:
- Windows Start Menu > Open OsGeo4W Shell in
administrator mode...
In the windows Start Menu, open OsGeo4W Shell (in administrator mode), and
execute this command:
pip install scikit-learn
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With Linux, if pip is not installed, just type in the terminal:
sudo apt-get install python-pip
sudo pip install scikit-learn

2.3. Installation of dzetsaka
Like every Qgis plugin, to install dzetsaka, in Qgis open menu / Plugin / Install
and search for dzetsaka. Click on install, the plugin automatically downloads and
install itself.
Since dzetsaka 2.1, the plugin is now compatible with the processing toolbox,
which means you can use dzetsaka in a processing chain.
Qgis features:
- Setup dzetsaka: Plugin > Setup or manage plugin >
Search for dzetsaka
3. Method
Lexicon:
●
●
●

NDCI: Normalized Difference Cloud Index allows to separate clouds and
shadows from the rest of the image.
TOA: Top of Atmosphere means the reflectance value at the top of
atmosphere.
ROI: Region of Interest, these are the polygons or points containing data
used to predict an image.

Figure 7.7 shows the processing of the 6 main steps to make the mapping of
pedicular tree species:
1- Convert images in TOA reflectance
2- Clouds mask creation with the NDCI
3- Regions Of Interest creation
4- Classification
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5- Correction of results (remove noises with a sieve)
6- Last treatment and merge all results in one.

Figure 7.7. Processing chain for mapping forests in Guiana Amazonian Park.

Figure 7.8. Step 1 diagram: convert image in TOA reflectance.

3.1. Images processing
The process (figure 7.8) is to take the raw SPOT-5 image and convert to the TOA
reflectance. Then, if some spatial lag is visible, georeference the TOA image.
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3.1.1. Top Of Atmosphere reflectance
SPOT-5 imagery need to be convert to TOA reflectance to homogenize spectral
information between images. [Optical Calibration] tool from Monteverdi is used
because it automatically finds metadata needed for conversion.
Monteverdi features:
- Convert to TOA : View > OTB Application > Optical
Calibration
This pretreatment is not necessary for Sentinel-2 images since the images are
distributed in 1C level (with TOA reflectance: https://scihub.copernicus.eu/dhus/).
Steps

Handling in Monteverdi

Convert raw data
imagery in Top Of
Atmosphere
reflectance

In Monteverdi:
● Click on: View / OTB Application
In OTB Application open:
● Optical Calibration
Load the SPOT-5 image and check if parameters are correctly
fulfilled with metadata.

Table 7.3. Compute Top Of Atmosphere reflectance

3.1.2. Georeference images within Qgis
Images must be correctly georeferenced to limit spatial lag. If they are not
sufficiently georeferenced, the use of a georeferenced dataset is needed to correct
spatial differences. In our case we use the IGN (National Institute of Geographic and
Forest Information) SPOT-5 mosaic of the French Guiana.
Qgis features:
- Plugin activation: Plugin > Manage and install plugins
> Select Gdal Georeferencer
- Georeferencing an image: Raster > Georeferencer >
Georeferencer ...

Steps
Georeferencing an
image

Qgis steps
In Qgis:
●

Load a georeferenced reference image
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Open the georeferencer tool
Raster > Georeferencer > Georeferencer

In Georeferencer tool:
● File > Open Raster
● Parameters > Transformation Settings:
○ Select the same Coordinates Reference System as
the reference raster
○ Choose the transformation type to Polynomial (1
or 2)
● After having added at least 3 points, activate the linking
between the georeferencer and Qgis:
○ View > Link Georeferencer to QGIS
○ This will make the same spatial extent between
your reference image and the future georeferenced
image
● The average error appears at the bottom right, in the edge of
the window. The closer the error is to 0, the better your
georeferencing.
Table 7.4. Georeferencing images

3.2. Clouds mask creation
Step 2 (figure 7.9) explains how to create a cloud mask for each image.

Figure 7.9. Step 2 diagram: Clouds mask computation.

3.2.1. Index computation (NDCI)
The climatic context of French Guiana results to a high cloud coverage,
including in the drying season (from August to November). It is common to have a
cloud coverage rate higher than 50%. Creating a cloud mask is primordial.
NDCI (Normalized Difference Cloud Index) is used to filter clouds and shadows.
account the difference between the ShortWave InfraRed (SWIR, band 4 of the
SPOT-5 image) and the red (band 2):
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NDCI =

¿−SWIR
¿+SWIR
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[7.1]

[Band Math] tool available in Orfeo Toolbox will be used to compute this index.
The tool does not support the function NDCI but it manages the NDVI. Simply
indicate band 2 and 4 to have the NDCI (red band and SWIR), or 2 and 3 for NDVI
(red band and near infrared), but the function will remain wrongly named "NDVI".
Qgis features:
- Compute NDCI: Processing Toolbox > Orfeo Toolbox >
Miscellaneous > Band Math...
Steps
Compute NDCI

Qgis steps
In Processing Toolbox:
● Orfeo Toolbox > Miscellaneous > Band Math
In Band Math:
● Write the formula:
"ndvi(im1b2,im1b4)"
Save the result with NDCI suffix (example SPOT5_NDCI.tif)
Table 7.5. Calculation of the NDCI

3.2.2. Clouds mask
NDCI values scale from -1 to 1. In order to have a quality cloud mask, it is
necessary to manually check the threshold above which the clouds are totally
filtered. As a general rule, the values which allow to filter the clouds oscillate
between 0.40 to 0.45. For each image, this threshold must be correctly defined and
visually validated.
The formula used in [Band Math] tool is:

im1b1 <= 0 , 40 ? 0 : 1
[7.2]
This formula replaces pixels that have a higher value to 0.4 by 1, if not value will
be 0.

Remote sensing of distinctives vegetations in Guiana Amazonian Park

13

Qgis features:
- Mask creation: Processing toolbox > Orfeo Toolbox >
Miscellaneous > Band Math...

Sentinel-2 and Landsat 8 images are provided with cloud and shadow masks.
However, in French Guiana these masks miss lot of clouds and shadows. The mask
made from the NDCI was also reproduced for these sensors.
The mask is then directly used when classifying with the dzetsaka plugin which
automatically detects the _mask suffix in addition to the filename.
Steps
Mask creation

Qgis steps
In Processing Toolbox:
● Orfeo Toolbox > Miscellaneous > Band Math
In Band Math:
● Write the formula
"im1b1 <= 0.4 ? 0:1"
Verify the threshold (here 0,40) is enough to remove clouds and
shadows. Then save the results with _mask suffix (example:
SPOT5_mask.tif)
Table 7.6. Creation of the clouds mask

4. Treatments

4.1. Creating training plots
Step 3 (Figure 7.10) consists in creating for each image a shapefile layer
containing ROI available in this image (polygons which contains data used for
training the model).
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Figure 7.10. Step 3 diagram (Creating ROI).

Class

Type

1

Parinari

2

Low vegetation

3

Mauritia flexuosa
forest

4

Inselberg

5

Açai forest

6

Clouds

7

Shadows

8

Light clouds

9

Water

10

Standard canopy

11

Nonstandard
canopy

Table 7.7. Nomenclature of the attribute table of a training plot (in green, the
classes of vegetations to map)

These polygons are identified with field data or by photo-interpretation.
Identification of different classes must be saved as a whole number. For an optimal
quality, creation of ROI need to be precise. Some rules must be respected:
●
●
●

ROI must select pixels having a homogenous spectral signature and avoid
borders with vegetations mixes.
There must be a sufficient number of pixels in each of the classes studied.
It is advisable to select areas distributed throughout the image to avoid
errors induced by the biogeographic effect.
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To improve knowledge of the study area, several helicopter overflights were
carried out to recover field references data.
Qgis features:
- Vector creation: Layer > Create Layer > New
Shapefile Layer...
Steps
Vector creation

Qgis steps
In Qgis:
Create a new vector file:
●
●
●
●
●

Layer > Create Layer > New Shapefile Layer
Choose Polygon type
Choose the same coordinate reference system (CRS)
as your image
Create a new field called class of type «whole
number», and a field Type of type «Text data» as seen
in the Table 3
Save (example name: SPOT5_ROI.shp)

Remote sensing of distinctives vegetations in Guiana Amazonian Park

16

Create new ROI
●
●

Toggle editing by clicking on editing icon
Create polygons of vegetations, clouds and shadows
(remember to use the nomenclature label for the
class column)

Table 7.8. Creation of the Regions of Interest.

4.2. Classification with dzetsaka plugin

Figure 7.11. Step 4 diagram (Classification).

4.2.1. List of algorithms available
4.2.1.1. Random-Forest
Random-Forest algorithm is an automatic learning method based on the creation
of different trees. This algorithm has proven itself on several works, including tree
species classification [FAS 16].
On the figure 7.12, three decision trees are shown: two trees (x2 < 5 and x3 < 5)
let the prediction of the class 2. x1 is the pixel value in the band 1, x2 on the band 2
and x3 on the band 3. One of the tree is based on pixel value in the infrared (x2 <5
for example), which considers if pixel value lower than 5 on this band, the algorithm
will predict it as water, or the tree will be more detailed.
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Figure 7.12. How Random-Forest works.

4.2.1.2. Support Vector Machine
Support Vector Machine (SVM) is a renowned algorithm which is based on
several kernels (linear, polynomial, gaussian...) in order to better adapt to the
problem to be solved. The kernel implemented in dzetsaka is the Radial Basis
Function (a gaussian kernel) which provides high quality results in tree species
classification [SHE 16].
Support vectors (circles touching dotted lines in figure 7.13) are samples that are
nearest to the separation margin (red line) and those which will have the more
importance for the classification. Circles in green and blue represents two different
classes. x1 and x2 are their values in two different spectral bands (Red and infrared
for example).

Figure 7.13. How SVM works.
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4.2.1.3. K-Nearest Neighbors (KNN)
K-Nearest Neighbors algorithm is one of the oldest. After having defined the
number of neighbors, the algorithm will class the pixel according to the value of the
nearest neighbor’s samples. This algorithm is very fast and need only one parameter:
the number of neighbors. In dzetsaka this parameter is chosen in a cross-validation
method to maximize the quality. In the figure 7.14, circles in blue and green
represent two classes. x1 and x2 are values in spectral bands (red and infrared for
example). We can show if the number of neighbors set is 3 (K=3), or 6 (K=6), the
predicted class of the yellow circle will stay the green class. To be precise, with 3
neighbors, two are from the green class and one is from the blue.

Figure 7.14. How K-Nearest Neighbors works

4.2.1.4. Gaussian Mixture Models (GMM)
Gaussian Mixture Models (GMM) is an algorithm which accounts the sum of
several gaussian. The closer the pixel is (in its reflectance values) the more weight it
will have. This algorithm is the faster available in dzetsaka and is natively available
(you do not need to install several dependencies). However, GMM is not suitable for
hyperspectral or multitemporal images (it needs to be manually configure in the
code), so use it with caution. We recommend it only on multispectral images.

4.2.1.5. Which algorithm to use?
There is no algorithm which is better than another. It depends of the works, of
the data to classify. There are several indices to evaluate the quality of an algorithm:
Cohen's kappa coefficient, Global Accuracy. The higher these indices are, the better
the classification is. If SVM algorithms tends to be the better is tree species
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classification on several works, it is almost impossible to use it with large Region Of
Interest (more than 10 000 pixels). Random-Forest is a good alternative. But it could
be interesting to use other algorithms such as GMM because of his quick execution.

4.2.2. Use of dzetsaka
4.2.2.1. Make a classification
Dzetsaka plugin allows the user to classify images with different algorithms. The
first thing to do is to link Regions of Interests with the same projection system of the
input image.
Once the classification is done with dzetsaka, a raster is generated and each pixel
has the label of the predicted class. It is also possible to save the algorithm model
(i.e., rules of the classification, to predict this model with another image), the
confusion matrix, or a confidence map (each pixel will have the confidence for the
predicted class, data is scaled between 0 and 1. 1 means total confidence, 0 no
confidence.)
Qgis features:
- Image classification: dzetsaka interface > Perform the
classification...
Steps

Qgis steps

Image classification

In dzetsaka plugin:
● Select image to classify;
● Select shapefile containing ROI;
● Select field containing typology (class column;
● In optional tab, select the mask if the name doesn’t end
with yourImageName_mask.tif.
●

Click on Settings button to choose the algorithm
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●
●
●

Optional settings

Click on “Perform the classification”;
Check the result, and add or remove ROI if needed,
Save the result (for example
SPOT5_classification.tif).
Several settings are optional, but can be really useful for this
work.
By default, dzetsaka will automatically find the mask of your
raster if you mask name ends with _mask.
In the optional tab, it is possible to save the confusion matrix
(Save matrix) that will be is CSV extension, or save the
confidence map.
When saving the matrix, dzetsaka will put the split (pixels to
keep for validation and pixels to keep for training) to 50%, which
mean half the pixel will be used for training. You can change this
setting.
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Table 7.9. Make a classification with dzetsaka plugin

4.2.2.2. Assess the classification quality
Two tools allow to assess the classification quality. First one is to shows the
algorithm confidence per pixel.
Qgis features:
- Classification Quality assessment: Check the case
confidence map box in dzetsaka
To get the confidence map, you need to check the box before the classification. It
results a raster with values scaled from 0 to 1, where 1 is the best confidence, and 0
the lower. It can be used to shows spatially where the algorithm lakes information
and where the confusion is the higher. It allows to add ROI, or to show on the
ground why the algorithm has no confidence in these cases.
Steps
Get the confidence
map

Qgis steps
In dzetsaka plugin:
● In the interface, check the confidence map box.
● Once classification is done, a raster will be generated:
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The more the value is lower (in black here), the more the
algorithm is not confident.
Table 7.10. Make a confidence map for assessing classification quality

Qgis features:
- Assessment of the classification quality: Dzetsaka >
Confusion matrix…

The second method is the creation of a confusion matrix. Once confusion matrix
box is checked, the split (percentage of pixels keep beside the classification) will
automatically set to 50%, which means 50% of the pixels will be used for
classification, and 50% will be you the validate the classification. It allows the
algorithms to only class the image with half of the pixels.
To get the global accuracy (percentage of pixels which are well predicted) or the
Kappa coefficient (global accuracy minus the hazard effect), it needs to open
Dzetsaka menu, then Confusion Matrix. This tool requires your ROI, the column
which contains your labels, and the classified raster. Once run, you will have your
kappa and global accuracy score.
Steps
Get Kappa
coefficient and
global accuracy.

Qgis steps
In Qgis:
● Click on: Dzetsaka > Confusion matrix
In Confusion Matrix windows:
● Load your classification raster
● Load your shapefile
● Select the field containing typology (class column)
● Click on Compare
In our example, kappa is 89.14% (0.89), and global accuracy is
95.17%, which means 95.17% pixels predicted have the same
label are those trained.
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Table 7.11. Compute a confusion matrix

4.3. Post classification
Once each classification is done, we can observe some noise. To remove these
noises, a sieve must be applied of the raster, which means objects below a certain
size (in pixels or in area) will be changed to this majority neighbor. Step 5 (Figure
7.15) correct classification defaults and allows to prepare the classification for the
final step.

Figure 7.15. Step 5 diagram (Post classification treatment).

To easier the merge of several images, values of unwanted classes will be
changed to NODATA. In this case clouds, shadows, and water will be convert to the
0 value.
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[Band Math] tool allows reclassing classes easily. Classes 6, 7, 8 and 9 (which
are clouds, shadows, light shadows and water) to 0 with this expression:

im1b1>= 6 && im1b1 <= 9 ? 0 : im1b1

[7.3]

To write an expression, it requires a question which can contains several
arguments (ʺ&&ʺ for ‘and’, and ʺ||ʺ for ʺorʺ). Once the question is over (ʺ?ʺ), the
first answer if the true one (in our case ʺ0ʺ), then the answer if the condition is
wrong (ʺ: ʺ). In this case, if the condition is not satisfied (im1b1 is 3 for example),
Ban Math will assign his im1b1 value (so value “3”).
To not make twice the same processing, it will be used the Processing Toolbox in
Qgis. This feature allows to chain different functions and to batch them. For
example, it is possible to create a model that will create NDCI image, then compute
the clouds mask, and classify the image. To introduce you to the model creation, a
short model will be created to sieve the predicted image and to reclass unwanted
classes.
Qgis features:
- Create a model: Processing Toolbox > Models > Tools
> Create new model…
- Filter objects giving their size: GDAL/OGR > [GDAL]
Analysis > Sieve…
- Reclass an image: Orfeo Toolbox > Miscellaneous >
Band Math
Steps
Create a model
Filter small objects

Qgis steps
In the Processing Toolbox:
● Models > Tools > Create new model
In model creation tool:
● Double click on a raster on the right;
● Then choose algorithms tab and search for:
○ GDAL/OGR > [GDAL] Analysis > Sieve
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Image reclass

In the Sieve window:
● Select image (predicted image);
● Choose the threshold to 10 pixels, which means a
sieve of 1000m², which remove noises of single pixels
and represents a suitable area to describe forests);
● Choose the pixel connection to 8, which means to
consider all neighbors from this pixel. Connection 4
take only into account only neighboring pixels);
● In sieved, write ‘raw_sieve’
● Click on OK.
In the Model creation tool:
● Select Band Math algorithm:
○ Orfeo Toolbox > Miscellaneous > Band Math
● In Input image, use previously raw_sieve file.
● Write the formula:
"im1b1>= 6 && im1b1 <= 9 ? 0 : im1b1"
●

In field OutputImage, write the given name that will be
ask for the use: here reclass_sieve.
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Run the model

In Processing Toolbox:
●
●

Search for: Model > Group Name > Model Name
Your algorithm appears in the list of models in the
processing toolbox

Table 7.12. Sieve and reclass the classification

5. Final processing
The last step (Figure 7.16) consists in merging every predicted image and to
delete unwanted area, such as habitat or mining territory.

Figure 7.16. Step 6 diagram (Merging results and final treatment).

5.1. Synthesis of predicted images
Climate of tropical forests induces a high cloudiness of images. For a great
accuracy mapping, it is necessary to overlay the classification results of different
dates. Ideally, these images should be close in time to avoid disturbances (for
example cuts). But the climate condition in Guiana make difficult to have several
images a year.
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[r.mapcalculator] tool from Grass 6 allows to generate a classification synthesis
for each scene, while removing pixels corresponding to the standard canopy forests.
Grass is recommended for this step because it handles images of different sizes,
which is very useful when the spatial extent is not the same between several
acquisition dates. If you are working with similar spatial extent, we recommend to
use the Orfeo Toolbox classification merging tools: FusionOfClassification (majority
vote, or Dempster-Shafer using the confusion matrix).
Inselbergs are best shown in the drying season (around October), so 2009 image
(A image in Figure 7.17) is the most important one. However, there was a problem
of calibration of the satellite sensor for this date, so only the inselbergs could be
extracted.

Figure 7.17. Synthesis example of 4 dates in the same SPOT-5 scene

On the 690-344 scene extract (Figure 7.17), [r.mapcalculator] of Grass allow to
remove standard canopy and non-standard canopy (classes 10 and 11) to merge later
different scenes between them.
Then a priority rule is given to prefer the 2009 image (which is A image), except
for the class n°2 (low vegetation). Be careful to not let empty space at the end of the
expression or your script will generate an error.
if((isnull(A) ||| A==0 ||| A==2 ||| A==10 ||| A==11),if((isnull(B)
||| B==0 ||| B==10 ||| B==11),if((isnull(C) ||| C==0 ||| C==10 |||
C==11),null(),C),B),A)
To translate this expression: if the image A pixel has a null value, or a value 2, 10
or 11, we look in the image B if it has a value different of null, 10 or 11, or we take
the image C (if different from null, 0, 10 or 11). If no condition is satisfied (i.e. all
pixels have the 10 value), the expression will class with a null value (white
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background shown at figure 7.17). It is important to use the three les trois bars ||| to
represent the ‘or’ because in Grass it means to use also the null values.
Qgis features:
- Data synthesis: Processing Toolbox > Grass
Commands > Raster > r.mapcalculator…
Steps
Select images and
classes to prioritize

Qgis steps
From the classification results, such as the confusion matrix or
the confidence map, select an order of the classes and images to
be prioritized.
In Processing Toolbox:
● GRASS commands > Raster > r.mapcalculator
In r.mapcalculator :
● Load images;
● Write the expression (A is the image 1, B the image 2). Be
careful to not let an empty space at the end of the
expression.
● Example: if((isnull(A)|||A==0|||A==2|||A==10|||
A==11),if((isnull(B)|||B==0|||B==10|||
B==11),if((isnull(C)|||C==0||| C==10 |||
C==11),null(),C),B),A)
Table 7.13. Synthesis for each scene

5.2. Global synthesis and cleaning unwanted areas
The final result per scene is merged to get a unique map of the whole study zone.
But, some anthropized areas have no interest in this mapping. In addition,
deforestation zones are easily confused with inselberg during the classification. A
final cleaning that takes account of the land cover data is therefore necessary. A
mask is created from agricultural and mining areas from the land cover layers.
Qgis features:
- Global synthesis: Processing Toolbox > GDAL/OGR >
Miscellaneous > Build Virtual Raster…
- Merge vector layers: Processing Toolbox > Qgis
geoalgorithms > Vector general tools > Merge vector
layers…
- Buffer: Processing Toolbox > Qgis geoalgorithms >
Vector geometry tools > Variable distance buffer…
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- Vector rasterization: Processing Toolbox > Orfeo
Toolbox > Vector Data Manipulation > Rasterization
(image)…
- Remove unwanted areas: Processing Toolbox > Orfeo
Toolbox > Miscellaneous > Band Math…
Steps
Global synthesis

Qgis steps
In Processing Toolbox:
● GDAL/OGR > Miscellaneous > Build Virtual Raster
In Build Virtual Raster tool:
● Load all the scenes (each synthesis by scene)
● Give a name to the virtual raster;
● Unselect ‘Layer Stack;
● Click on Ok.

Buffer

In Processing Toolbox:
● QGIS geoalgorithms > Vector geometry tool > Fixed
distance buffer
In Fixed distance buffer:
● If you are unsure of the areas to be removed, we
recommend that you create a buffer.
Choose the distance (100 for 100m here because it is a
metric projection). To check the measure unit, refer to
the spatialreference site. For example, for Lambert-93
(EPSG: 2154):
http://spatialreference.org/ref/epsg/2154/html/)
● Check the Dissolve result to merge buffers
● Save the result

Vector rasterization

In Processing Toolbox:
● Orfeo Toolbox > Vector Data Manipulation >
Rasterization (image)…
In Rasterization (image) tool:
● Load vectors areas to remove
● Load the global synthesis
● Set the background value to 1
● Select rasterization mode to binary
● Set the foreground value to 0
● Save the result
In Qgis menu:
● Raster > Raster Calculator…
In Raster Calculator tool:
● Load layer areasToRemove@1 (means band 1 from
areasToRemove image)
● Multiply it by the fusion_scenes image:

Temporary final
result
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" areasToRemove@1" * "fusion_scenes@1"
Final result

● Save the result
In Processing Toolbox:
● GDAL/OGR > Conversion > Translate
In Translate tool:
● Input image: last result
● Null value: 0
In advanced parameters:
● Raster type: byte
● GeoTIFF options: LZW
● Save the final result
Table 7.14. Global synthesis and cleaning

5.3. Statistical validation - Limits
Field data are very difficult to access in southern Guiana. Despite some
helicopter and field mission, data gathered led to too much imprecision. Indeed,
from the helicopter, information has important spatial lag, whereas ground data
potentially concern too small formations, not detectable with a spatial resolution of
100m².
To overcome this problem, a training game containing new training plots was
created from the 2015 SPOT-6 mosaic. These are new ROIs that are visible by
photo-interpretation from this image, it is used as a validation set for the final result
got previously. The mosaic is correctly georeferenced, and has the advantage of
having a better spatial resolution.
A confusion matrix is obtained using the [ComputeConfusionMatrix] tool from
Orfeo Toolbox. Inselbergs, low vegetation and Parinari forests have shown very
good classification results. However, inselbergs and low vegetation classes should
be detailed, as they include several species. Results for parinari species and Açai
palm forests are not convincing. These confusions appear to be related to the fact
that palm areas are generally very small, and there are only few geolocalized
learning areas.

Qgis features:
- Compute confusion matrix: Processing Toolbox >
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Orfeo Toolbox > Learning >
ComputeConfusionMatrix(vector)…
Steps
Create a
reference layer
Compute the
confusion
matrix

Qgis steps
In the same way, as when creating training plots, digitize polygons
from a new image (ideally with better spatial resolution), or use only
reference field data.
In the Processing ToolBox:
● Orfeo Toolbox > Learning > ComputeConfusionMatrix
(vector)
In ComputeConfusionMatrix :
● Input image (Final classification);
● Input reference vector data (ROI);
● Set Field name (class);
● Value for nodata: 0;
● Save the result as csv type

Table 7.15. Validate the final classification

6. Conclusion
This classification follows a standard method of landcover mapping with
automatic analysis of remote sensing images. The contribution of this chapter is the
implementation in an Open Source and user-friendly tool: Qgis. Moreover, with the
processing toolbox, it now allows to combine multiple algorithms (and to use them
in batch). This ability is essential for remote sensing works on large areas or with a
large number of images, as in this case in French Guiana.
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